Legacy widgets are no longer supported and will be replaced by an improved version in the future.